Re: Re: [RFC][DISCUSSION] script() and script_once()

From: Date: Thu, 05 Feb 2015 04:38:13 +0000
Subject: Re: Re: [RFC][DISCUSSION] script() and script_once()
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-81860@lists.php.net to get a copy of this message
The name seems ambiguous , how about "require_script/once" to match "do_sth" pattern? On 5 February 2015 at 10:03, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote: > Hi all, > > On Thu, Feb 5, 2015 at 10:53 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote: > > > I would like to discuss my "must have it in PHP 7" item. > > > > PHP RFC: script() and script_once() > > https://wiki.php.net/rfc/script_and_script_once > > > > Since script()/script_once() is almost copy of require()/require_once(), it > could be > INI option. > > require_embed = On/Off > > This allows existing PHP script to be secure without rewriting. If many of > you like > this, I'll change the RFC. > > Regards, > > -- > Yasuo Ohgaki > yohgaki@ohgaki.net >

« previous php.internals (#81860) next »