RE: [PHP-DEV] Scalar Type Hints v0.4

From: Date: Wed, 18 Feb 2015 15:34:33 +0000
Subject: RE: [PHP-DEV] Scalar Type Hints v0.4
References: 1 2 3 4 5 6 7  Groups: php.internals 
Request: Send a blank email to internals+get-83085@lists.php.net to get a copy of this message
> De : Zeev Suraski [mailto:zeev@zend.com] > > If we do implement the single-mode, stricter-than-pure-weak and > weaker-than-pure-strict ruleset, we could introduce a new set of conversion > functions, along the lines of safe_int(), that would follow the same rules > as the corresponding type hints (i.e. accept (int) 32, (string) "32", but > not (float) 32.7, or (string) "32 dogs"). Nice. I like it : create a set of userland functions aligned on zend_parse_arg_xxx(). Just remains to bikeshed on function names :) Regards François

« previous php.internals (#83085) next »