Re: RFE to allow dirname($foo, 2)

From: Date: Sun, 26 Jul 2015 18:44:15 +0000
Subject: Re: RFE to allow dirname($foo, 2)
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-87301@lists.php.net to get a copy of this message
Hi Scott! 2015-07-25 19:42 GMT+02:00 Scott Arciszewski <scott@paragonie.com>: > What's easier to read and less likely to result in bugs? > > require_once __DIR__ . '/../../../../autoload.php'; > > or > > require_once dirname(__FILE__, 5) . '/autoload.php'; That's on everyone's own, but for me it's the first. However, it couldn't be a disaster having ability to choose other option for those, who are not familiar with relative paths. :-) Best regards, Kubo2, Jakub Kubíček

« previous php.internals (#87301) next »