Re: [RFC] Void Return Type (v0.2, reöpening)

From: Date: Thu, 15 Oct 2015 21:03:36 +0000
Subject: Re: [RFC] Void Return Type (v0.2, reöpening)
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-88841@lists.php.net to get a copy of this message
Hi everyone, Andrea Faulds wrote:
I'm reviving my Void Return Type RFC, this time for PHP 7.1: https://wiki.php.net/rfc/void_return_type Please read it and tell me your thoughts!
Since the void/null naming issue has been a frequently-asked question, I've added a subsection to the RFC explaining why I chose this name. It doesn't really say anything I haven't said already, it just summarises it. In particular, it lists a bunch of languages using void, some of which do what PHP does. The new section is here: https://wiki.php.net/rfc/void_return_type#why_call_it_void_and_not_null Thanks. -- Andrea Faulds http://ajf.me/

« previous php.internals (#88841) next »