Re: Re: [RFC] Void Return Type (v0.2, re öpening)

From: Date: Fri, 16 Oct 2015 14:09:15 +0000
Subject: Re: Re: [RFC] Void Return Type (v0.2, re öpening)
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-88856@lists.php.net to get a copy of this message
Den 2015-10-15 kl. 23:03, skrev Andrea Faulds:
Hi everyone, Andrea Faulds wrote:
I'm reviving my Void Return Type RFC, this time for PHP 7.1: https://wiki.php.net/rfc/void_return_type Please read it and tell me your thoughts!
Since the void/null naming issue has been a frequently-asked question, I've added a subsection to the RFC explaining why I chose this name. It doesn't really say anything I haven't said already, it just summarises it. In particular, it lists a bunch of languages using void, some of which do what PHP does. The new section is here: https://wiki.php.net/rfc/void_return_type#why_call_it_void_and_not_null Thanks. Good summary and motivation! Should be a very good reason
to have any other name then void as return type. r//Björn Larsson

« previous php.internals (#88856) next »