Re: [RFC] Normalize token_get_all() output (with flag)
| From: | Nikita Popov | Date: | Tue, 05 Jan 2016 14:16:57 +0000 |
| Subject: | Re: [RFC] Normalize token_get_all() output (with flag) | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-90090@lists.php.net to get a copy of this message | ||
On Mon, Jan 4, 2016 at 11:56 PM, Sara Golemon <pollita@php.net> wrote:
> I swear, 2016 isn't going to be "An RFC per day" year, but...
>
> https://wiki.php.net/rfc/token-get-always-tokens
>
> This should be pretty non-controversial. I hope?
>
>
+1
Would be nice if someone could come up with a more explicit name for the
flag. TOKEN_FULL is not obvious, at least to me. TOKEN_ALWAYS_ARRAY?
I'd also like to have a flag TOKEN_NO_LINENOS with deduplication of token
arrays, but that's a separate matter...
Nikita