Re: [RFC] Normalize token_get_all() output (with flag)
| From: | Sara Golemon | Date: | Tue, 05 Jan 2016 19:45:04 +0000 |
| Subject: | Re: [RFC] Normalize token_get_all() output (with flag) | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-90140@lists.php.net to get a copy of this message | ||
On Tue, Jan 5, 2016 at 6:16 AM, Nikita Popov <nikita.ppv@gmail.com> wrote:
> Would be nice if someone could come up with a more explicit name for the
> flag. TOKEN_FULL is not obvious, at least to me. TOKEN_ALWAYS_ARRAY?
>
Yeah, I'm not a huge fan of the name either, but I couldn't come up
with anything better at the time.
Maybe TOKEN_ASSOC? Since it provides associative array elements (as
opposed to the current indexed array behavior)
> I'd also like to have a flag TOKEN_NO_LINENOS with deduplication of token
> arrays, but that's a separate matter...
>
Not sure what you're suggesting here. Can you elaborate?
-Sara