Re: Suggestion
| From: | Kalle Sommer Nielsen | Date: | Mon, 29 Aug 2016 13:06:51 +0000 |
| Subject: | Re: Suggestion | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-95497@lists.php.net to get a copy of this message | ||
Hi Mathias
2016-08-29 15:03 GMT+02:00 Mathias Grimm <mathiasgrimm@gmail.com>:
> Hi,
> I have a suggestion, maybe many gave it before.
>
> My suggestion is the optional use of the keyword "function" inside classes,
> interfaces and traits.
> It would look much more clean while removing the redundancy.
This was discussed on internals 2 years ago, back when PHP7 was being designed:
http://marc.info/?t=141235344900003&r=1&w=2
--
regards,
Kalle Sommer Nielsen
kalle@php.net