Re: Change in type-hint representation
| From: | Nikita Nefedov | Date: | Wed, 11 Jan 2017 19:20:58 +0000 |
| Subject: | Re: Change in type-hint representation | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-97698@lists.php.net to get a copy of this message | ||
> On 11 Jan 2017, at 19:37, Dmitry Stogov <dmitry@zend.com> wrote:
>
> The patch was updated according to feedback: added comments, better names and encapsulation,
> less magic, better code reuse, keep a free bit in zend_type for future extension.
>
> <https://gist.github.com/dstogov/1b25079856afccf0d69f77d499cb0ab1>
>
>
>
> <https://gist.github.com/dstogov/1b25079856afccf0d69f77d499cb0ab1>
>
>
> https://gist.github.com/dstogov/1b25079856afccf0d69f77d499cb0ab1
>
>
> Thanks. Dmitry.
Thanks for the patch, looks good to me!