note 24681 added to install.linux

From: Date: Sun, 25 Aug 2002 16:22:55 +0000
Subject: note 24681 added to install.linux
Groups: php.notes 
Request: Send a blank email to php-notes+get-35596@lists.php.net to get a copy of this message
Updated instructions for installing Apache 2.x with PHP4 and MySQL: (1) Download httpd-2.0.40-i686-pc-linux-gnu-rh73.tar.gz from http://www.apache.org/dist/httpd/binaries/linux/ (2) Download php4-latest.tar.gz from http://snaps.php.net/ (3) tar -xzvf httpd-2.0.40-i686-pc-linux-gnu-rh73.tar.gz cd httpd* ./configure --prefix=/Apps/apache --enable-module=so make make install (4) tar -xzvf php-4.2.2.tar.gz cd php* ./configure --with-mysql --with-apxs2=/path/to/apxs (To find path/to/apxs, do slocate -u /, then slocate apxs) make make install cp php.ini-dist /usr/local/lib/php.ini (5) Add the following to httpd.conf AddType application/x-httpd-php .php LoadModule php4_module /path/to/libphp4.so (To find path/to/libphp4.so, do slocate -u /, then slocate libphp4.so) (6) Restart httpd: /path/to/apachectl restart Notes: Never had problems with ./configure or make with apache. But wow, a world of pain in trying to do a make on php. (Make sure to use --enable-module=so, when doing a ./configure with apache.) I kept getting make errors with php (No problems with ./configure). Thanks to pvenable@cs.cmu.edu, I found out the problem was with php-4.2.2.tar.gz. Make sure to get php4-latest.tar.gz! Hope this helps someone out there. Good luck! -- http://www.php.net/manual/en/install.linux.php http://master.php.net/manage/user-notes.php?action=edit+24681 http://master.php.net/manage/user-notes.php?action=delete+24681 http://master.php.net/manage/user-notes.php?action=reject+24681

« previous php.notes (#35596) next »