note 53757 added to ref.mysql

From: Date: Sun, 12 Jun 2005 08:06:21 +0000
Subject: note 53757 added to ref.mysql
Groups: php.notes 
Request: Send a blank email to php-notes+get-90284@lists.php.net to get a copy of this message
I recently upgraded from php 5.02 to php 5.04 and found that the included php_mysql.dll was incompatable with mySQL 4.0.22. The dll was trying to load mysql_createdb() and mysql_dropdb(), which are not supported in mySQL 4 and higher. So, I was getting a cannot load procedure error when starting php on my web server. I was able to fix this by editing those two commands out of the source and recompiling php_mysql.dll. Maybe this will help someone who has had the same issue. For convienience, here is a link to the new php_mysql.dll that I compiled (hosted on my home server): ftp://ftp.crystalhome.net/php_mysql.dll I am not sure if this is the right place to post this, but hopefully it helps people. ---- Manual Page -- http://www.php.net/manual/en/ref.mysql.php Edit -- http://master.php.net/manage/user-notes.php?action=edit+53757 Delete: added to the manual -- http://master.php.net/manage/user-notes.php?action=delete+53757&report=yes&reason=added+to+the+manual Delete: bad code -- http://master.php.net/manage/user-notes.php?action=delete+53757&report=yes&reason=bad+code Delete: spam -- http://master.php.net/manage/user-notes.php?action=delete+53757&report=yes&reason=spam Delete: useless -- http://master.php.net/manage/user-notes.php?action=delete+53757&report=yes&reason=useless Delete: other reasons -- http://master.php.net/manage/user-notes.php?action=delete+53757&report=yes Reject -- http://master.php.net/manage/user-notes.php?action=reject+53757&report=yes Search -- http://master.php.net/manage/user-notes.php

« previous php.notes (#90284) next »