#21382 [Ver]: install of phpDocumentor fails
| From: | jmcastagnetto@php.net | Date: | Sat, 04 Jan 2003 01:04:36 +0000 |
| Subject: | #21382 [Ver]: install of phpDocumentor fails | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-12073@lists.php.net to get a copy of this message | ||
ID: 21382
Updated by: jmcastagnetto@php.net
Reported By: greg@chiaraquartet.ent
Status: Verified
Bug Type: PEAR related
Operating System: win98
PHP Version: 4.3.0
New Comment:
More clues.
To check if the problem was the creation of the tarball package itself
I did:
% cd tmp/PhpDocumentor-1.2.0beta1
% cp ../package.xml .
% pear package
File
phpDocumentor/Converters/CHM/default/templates/default/templates/basicindex.tpl
does not exist
And indeed that file does not exist. I wonder how the package got
created OK in the first place.
The problem is line 247 in package.xml:
<file role="php" baseinstalldir="phpDocumentor"
md5sum="d93134f0d62acffaae22e14db015fb08"
name="phpDocumentor/Converters/CHM/default/templates/default/templates/basicindex.tpl"/>
Commented that out and retried, giving another error:
"File
phpDocumentor/Converters/CHM/default/templates/default/templates/classleft.tpl
does not exist"
So I commented out the whole CHM section, and retrying I got:
File
phpDocumentor/Converters/HTML/default/templates/default/constants_detail.inc.html
does not exist
Bottomline. If Greg is using Windows to create the tarball, then that
may be the reason why things are failing. Is there a limit to the paths
in Windows? (I have no idea, I do not use that OS).
BTW, I just tried getting a to PhpDocumentor's CVS and got the error:
"...
U phpdoc/Documentation/Release-old/Release-1.1.0rc1
U phpdoc/Documentation/Release-old/Release-1.1.0rc2
cvs server: Updating phpdoc/Documentation/old
cvs server: failed to create lock directory for
`/opt/cvsroot/phpdoc/Documentation/old'
(/opt/cvsroot/phpdoc/Documentation/old/#cvs.lock): Permission denied
cvs server: failed to obtain dir lock in repository
`/opt/cvsroot/phpdoc/Documentation/old'
cvs [server aborted]: read lock failed - giving up
..."
So I will download a snapshot and check what's going on.
Previous Comments:
------------------------------------------------------------------------
[2003-01-03 18:42:13] jmcastagnetto@php.net
The problem is not OS specific, doing:
% pear install PhpDocumentor
downloading PhpDocumentor-1.2.0beta1.tgz ...
...done: 666,630 bytes
failed to write
/export/dredox1/devel_server/php/lib/php/phpDocumentor/phpDocumentor/Converters/CHM/default/templates/default/templates/.tmpbasicindex.tpl
gives also an error on Solaris 8, using php4-CVS
I downloaded the tarball it does not seem to contain any file named
".tmpbasicindex.tpl". So the options were that (1) the tarball contents
are fubared somehow (the list looks OK), or (2) PEAR::Archive_Tar is
messing up at some point.
To check the tarball, I just used Gnu tar:
% gtar -zxvf PhpDocumentor-1.2.0beta1.tgz
then:
% cd
PhpDocumentor-1.2.0beta1/phpDocumentor/Converters/CHM/default/templates/default/templates
Finally:
% ls -Al
total 112
-rw-r--r-- 1 jesusmc asd 246 Dec 23 20:44 blank.tpl
-rw-r--r-- 1 jesusmc asd 2194 Dec 23 20:44 class.tpl
-rw-r--r-- 1 jesusmc asd 277 Jun 16 2002 hhp.tpl
-rw-r--r-- 1 jesusmc asd 675 Dec 23 20:44 index.tpl
-rw-r--r-- 1 jesusmc asd 777 Dec 23 20:44 page.tpl
-rw-r--r-- 1 jesusmc asd 125 Dec 23 18:05 ric.tpl
-rw-r--r-- 1 jesusmc asd 1248 Dec 23 20:44 var.tpl
And as you can see no ".tmpbasicindex.tpl" exists. Not even when I
used:
% cd /tmp/PhpDocumentor-1.2.0beta1
% find ./ -name ".tmpbasicindex*" -print
Had not look at the PEAR::Archive_Tar yet
------------------------------------------------------------------------
[2003-01-03 04:57:48] katana@katana-inc.com
I get the same error, or something similar, while installing
http://pear.php.net/get/PhpDocumentor-1.2.0beta1.tgz,
but this time on
windows XP (PHP 4.3.0):
D:\programs\httpd\php>pear install
http://pear.php.net/get/PhpDocumentor-1.2.0beta1.tgz
downloading PhpDocumentor-1.2.0beta1.tgz ...
...done: 666,630 bytes
failed to write
\programs\httpd\php\pear\phpDocumentor\phpDocumentor\Converters\CHM\default\templates\default\templates\.tmpbasicindex.tpl
------------------------------------------------------------------------
[2003-01-03 01:58:08] greg@chiaraquartet.ent
using the web frontend, attempts to install phpDocumentor fail, due to
inability to write to long path
C:\phpdev\php-4.3.0-Win32\pear\phpDocumentor\phpDocumentor\Converters\CHM\default\templates\default\templates
probably because it's longer than 128 chars?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21382&edit=1