Re: PHP5 and namespaces for PEAR packages.

From: Date: Sat, 05 Apr 2003 06:19:25 +0000
Subject: Re: PHP5 and namespaces for PEAR packages.
References: 1 2  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-14906@lists.php.net to get a copy of this message
Martin Jansen wrote: > It would be cool to hear some comments from Sebastian, as he as been > working with ZE2 a lot recently. The Zend Engine 2 introduces non-nested namespaces, but offers syntax sugar to "emulate" nesting by allowing colons in namespace names. That means that the engine sees no relation between, for instance, PEAR:Package::aClass and PEAR:Package::anotherClass But to a human reader of the code the relation is clear: aClass and anotherClass belong to the same package. IMHO, we should definitely leverage this syntax sugar and go with PEAR:Package::Class for the namespace/class naming scheme. -- Sebastian Bergmann http://sebastian-bergmann.de/ http://phpOpenTracker.de/ Did I help you? Consider a gift: http://wishlist.sebastian-bergmann.de/

« previous php.pear.dev (#14906) next »