#23393 [Asn]: upload of phpDocumentor fails

From: Date: Mon, 02 Jun 2003 07:34:25 +0000
Subject: #23393 [Asn]: upload of phpDocumentor fails
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-16883@lists.php.net to get a copy of this message
ID: 23393 User updated by: greg at chiaraquartet dot net Reported By: greg at chiaraquartet dot net Status: Assigned Bug Type: PEAR related Operating System: pear.php.net PHP Version: 4.3.2RC2 Assigned To: imajes New Comment: solution found! I only had to install linux, compile php, apache, checkout pearweb from cvs, troubleshoot mysql, and then I was able to both replicate the bug and solve it. The solution is STAGGERINGLY simple :) It doesn't even involve coding. php.ini has 2 settings for uploads, and BOTH must be at 16 MB or file uploads will fail (this is *not* a HTTP_Upload bug, except that HTTP_Upload should check to see if the size and tmpname parameters are set in $_FILES and raise an error saying php.ini settings are too low for file size, or file too big, and quote the max allowed size). Here's the settings that must be changed: upload_max_filesize = 16M post_max_size = 16M I had post_max_size = 8M and it still gave me E_FAIL_MOVE. When I changed it to 16, voila, everything worked! Please change this asap (since it is so easy), and I'll upload a release of phpDocumentor. Greg Previous Comments: ------------------------------------------------------------------------ [2003-05-31 13:52:40] greg at chiaraquartet dot net not to be annoying, but this bug is a month old, and we are now ready for phpDocumentor 1.2.0 FINAL, the stable release. This is a show-stopper for users of phpDocumentor, they will no longer be able to rely on PEAR for the latest release. Greg ------------------------------------------------------------------------ [2003-05-17 09:09:59] greg at chiaraquartet dot net Hello, Although upload generally works, it specifically does not work for phpDocumentor 1.2.0rc2. Any chance of searching for the problem? Perhaps there is a file size limit that is less than the size of PhpDocumentor-1.2.0.tgz? Make sure the php.ini setting for max file upload size is indeed 16MB as is claimed, and then perhaps verify that the copy() command can copy large enough files on the platform, this might be a PHP bug and not a PEAR bug, which should be fixed in the release of 4.3.2 Thanks, Greg ------------------------------------------------------------------------ [2003-05-11 15:11:05] greg at chiaraquartet dot net verified, it still gives the same error. The tgz is available at http://www.phpdoc.org/~CelloG/PhpDocumentor-1.2.0rc2.tgz ------------------------------------------------------------------------ [2003-05-11 01:28:13] mj@php.net Can you please try to upload it again? There have been numerous new uploads showing that the upload generally works. ------------------------------------------------------------------------ [2003-05-03 01:53:25] alan_k@php.net Looks like a config problem on the server - probably write access needs enabling the target directory.. James is probably the one to sort this out (not that he's got enought todo :).. Anyone know which directory the file is supposed to go to? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/23393 -- Edit this bug report at http://bugs.php.net/?id=23393&edit=1

« previous php.pear.dev (#16883) next »