#23393 [Csd]: Archive_Tar::createModify can't handle paths with spaces

From: Date: Wed, 04 Jun 2003 05:21:59 +0000
Subject: #23393 [Csd]: Archive_Tar::createModify can't handle paths with spaces
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-16980@lists.php.net to get a copy of this message
ID: 23393 User updated by: greg at chiaraquartet dot net -Summary: upload of phpDocumentor fails Reported By: greg at chiaraquartet dot net Status: Closed Bug Type: PEAR related -Operating System: pear.php.net +Operating System: Windows XP -PHP Version: 4.3.2RC2 +PHP Version: 4.3.2 Assigned To: imajes New Comment: phpDocumentor is about 2.1MB. 16 MB is just the documented limit of file size. If that is too big, it should simply state a different number on the webpage. Thanks for fixing this, I'll do the upload tomorrow or the next day, we are verifying that everything is OK with the switch from GPL to PHP license Greg Previous Comments: ------------------------------------------------------------------------ [2003-06-03 21:35:34] cox at idecnet dot com Note the TODO inside the HTTP_Upload code: * TODO: * - addapt the class to new upload features of the 4.2 (?) release * (the new error entry in HTTP_POST_FILES) The class was coded under 4.1, and the PHP upload code changed since that, working with some differences. It has to be updated because it indeed doesn't match the correct error message. ------------------------------------------------------------------------ [2003-06-03 19:39:09] imajes@php.net should be fixed now, but Greg... 16mb is a bit huge.. what the hell have you got in that package? ------------------------------------------------------------------------ [2003-06-02 02:34:24] greg at chiaraquartet dot net solution found! I only had to install linux, compile php, apache, checkout pearweb from cvs, troubleshoot mysql, and then I was able to both replicate the bug and solve it. The solution is STAGGERINGLY simple :) It doesn't even involve coding. php.ini has 2 settings for uploads, and BOTH must be at 16 MB or file uploads will fail (this is *not* a HTTP_Upload bug, except that HTTP_Upload should check to see if the size and tmpname parameters are set in $_FILES and raise an error saying php.ini settings are too low for file size, or file too big, and quote the max allowed size). Here's the settings that must be changed: upload_max_filesize = 16M post_max_size = 16M I had post_max_size = 8M and it still gave me E_FAIL_MOVE. When I changed it to 16, voila, everything worked! Please change this asap (since it is so easy), and I'll upload a release of phpDocumentor. Greg ------------------------------------------------------------------------ [2003-05-31 13:52:40] greg at chiaraquartet dot net not to be annoying, but this bug is a month old, and we are now ready for phpDocumentor 1.2.0 FINAL, the stable release. This is a show-stopper for users of phpDocumentor, they will no longer be able to rely on PEAR for the latest release. Greg ------------------------------------------------------------------------ [2003-05-17 09:09:59] greg at chiaraquartet dot net Hello, Although upload generally works, it specifically does not work for phpDocumentor 1.2.0rc2. Any chance of searching for the problem? Perhaps there is a file size limit that is less than the size of PhpDocumentor-1.2.0.tgz? Make sure the php.ini setting for max file upload size is indeed 16MB as is claimed, and then perhaps verify that the copy() command can copy large enough files on the platform, this might be a PHP bug and not a PEAR bug, which should be fixed in the release of 4.3.2 Thanks, Greg ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/23393 -- Edit this bug report at http://bugs.php.net/?id=23393&edit=1

« previous php.pear.dev (#16980) next »