Re: publicweb role

From: Date: Thu, 04 Sep 2003 22:44:19 +0000
Subject: Re: publicweb role
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-21084@lists.php.net to get a copy of this message
On 4 Sep 2003 at 18:19, Greg Beaver wrote: > As it has been 2 months since I first posted the publicweb role patch, > and have received no negative feedback (I'm not counting the "wait for > feedback" as negative), I'm assuming you all like it. I have taken a > peek at the data directory, and it is rarely used for web stuff, so I > think it is better to create a specific role. A solution for making > sure people have set it is to not provide a default value - and to > raise an error with instructions when the user tries to install a > package for the first time that uses the publicweb role. In other > words, they would see this: > > $ pear install PhpDocumentor > Error - this package uses the publicweb role. Please execute this > command: "pear config-set publicweb_dir /path/to/webserver/directory" > to configure a location for web-related files. This should be a > subdirectory of the directory public web files are located in. $ pear > config-set publicweb_dir /usr/share/www/htdocs/pear $ pear install > PhpDOcumentor Install OK > > The code for this is relatively simple, and a few guesses can be made > based on standard configuration, and the web interface can make a very > educated guess based on its own location. > > Otherwise, the change would work as in the patch I provided 2 months > ago. This same patch is available at phpdoc.org. Hmm Greg, I like your thoughts. :-) Nothing against this from my side. But maybe from the core group (Pierre, Tomas, ...) could reflect there core-group-sight on this topic? Does this maybe need any internal votes inside the group because the publicweb is a big change to the core / DTD / ...? Stefan

« previous php.pear.dev (#21084) next »