Re: publicweb role
| From: | Greg Beaver | Date: | Sat, 06 Sep 2003 13:18:49 +0000 |
| Subject: | Re: publicweb role | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-21116@lists.php.net to get a copy of this message | ||
Hi Tomas,
I think we have a different understanding of what publicweb is, here is a few examples.
HTML_TreeMenu is not an application by any standard. It contains both image files and .js files that are static. Currently it is impossible to locate them without intimate knowledge of how pear installs things, and if you attempt to run the example, it will successfully display the dropdown menu, but no JS example is displayed, and no error either. My Error_Handler package displays a few images in the HTML logger, and currently, the only way to guarantee that they will display properly is to hack in a base64decode of the image data and echo it - which makes no sense, since it is static image data.
Neither one of these examples is a standalone application, but both can be used by applications. So, I don't think publicweb has anything to do with applications, at least not any more than any other role does.
Regards,
Greg
Tomas V.V.Cox wrote:
Why not call this role "app"? For example: $ pear install phpnuke This package contains files that need to be installed in a visible directory out the pear main directory. Please use: "pear -c app_dir install phpnuke" If you want to manually set the app_dir, the installation should be done under <app_dir>/<package_name>. I'm not sure if that would work for all php apps, we could just pick 3 or 4 of the most popular ones and do some tests. I guess that we will inmediatly need the pre-post install script feature done, besides others. How that sounds? Tomas V.V.Cox On Friday, September 5, 2003 0:19, Greg Beaver wrote:Hi all,As it has been 2 months since I first posted the publicweb role patch, and have received no negative feedback (I'm not counting the "wait for feedback" as negative), I'm assuming you all like it. I have taken a peek at the data directory, and it is rarely used for web stuff, so I think it is better to create a specific role. A solution for making sure people have set it is to not provide a default value - and to raise an error with instructions when the user tries to install a package for the first time that uses the publicweb role. In other words, they would see this:$ pear install PhpDocumentor Error - this package uses the publicweb role. Please execute this command: "pear config-set publicweb_dir /path/to/webserver/directory" to configure a location for web-related files. This should be a subdirectory of the directory public web files are located in. $ pear config-set publicweb_dir /usr/share/www/htdocs/pear $ pear install PhpDOcumentor Install OKThe code for this is relatively simple, and a few guesses can be made based on standard configuration, and the web interface can make a very educated guess based on its own location.Otherwise, the change would work as in the patch I provided 2 months ago. This same patch is available at phpdoc.org.Greg