Re: Subject/Observer design pattern in PEAR

From: Date: Wed, 21 Jul 2004 20:20:34 +0000
Subject: Re: Subject/Observer design pattern in PEAR
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-32219@lists.php.net to get a copy of this message
Philippe Jausions wrote:
Hi, Just wondering if the PEAR group advised about the member and method names to be used for the Subject/Observer design pattern? - Add observer - Remove observer - Notify observers - Constraint on object type for observers - ID of observers Apparently there is no consistency in the PEAR packages that use that pattern.
So far, there is no standard naming convention for such things. There was merely the private/public distinction. However, certain names have become established for certain functions (e.g., toHtml, toString, etc.). There certainly would be some benefit in promoting consistency :-) Klaus

« previous php.pear.dev (#32219) next »