Re: [PEPr] +1 for RDF::RDF
| From: | Lukas Smith | Date: | Tue, 31 Aug 2004 10:40:13 +0000 |
| Subject: | Re: [PEPr] +1 for RDF::RDF | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-33107@lists.php.net to get a copy of this message | ||
Martin Jansen wrote:
On Sat Aug 28, 2004 at 11:1036PM +0200, Lukas Smith wrote:PEPr wrote:According to the coding standards, classes like RDF_DBModel should be renamed to RDF_Model_DB.
I'm not sure there is such a passage in the coding standards, but I believe that my suggested naming scheme follows common sense: RDF_DBModel is a subclass of RDF_Model, which is indicated by naming it RDF_Model_DB.The original RAP API also had a class "object" from which a bunch of classes where derived (statement, blanknode etc). I have stuck this class into RDF.php ... The class doesnt do much and I think it mainly existed for forward compatibility or something. What do people think about it? regards, Lukas