[PEPr] Comment on System::System_Serial

From: Date: Fri, 24 Sep 2004 08:57:52 +0000
Subject: [PEPr] Comment on System::System_Serial
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-33530@lists.php.net to get a copy of this message
Martin Jansen (http://pear.php.net/user/mj) has commented on the proposal for System::System_Serial. Comment: In addition to the other comments a bit more: 1) PEAR has the so called "one-class-per-file" convention, which means that multiple classes should end up in multiple files. 2) Why don't you simply use return PHP_OS; in _determineOS()? 3) I'd suggest to rename getLine() to readLine() and getArray() to readLines(). 4) I'm by no means an expert in serial communication, but shouldn't there be a way to change the value of $badCommandResponse in getArray()? (There may be systems that use a different protocol dialect.) 5) I'm missing documentation for the package. Are you going to write some? Generally this looks like a useful addition for PEAR. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=149 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#33530) next »