[PEPr] Comment on Math::Map_Projection

From: Date: Sun, 13 Mar 2005 14:56:42 +0000
Subject: [PEPr] Comment on Math::Map_Projection
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-36671@lists.php.net to get a copy of this message
Philippe Jausions (http://pear.php.net/user/jausions) has commented on the proposal for Math::Map_Projection. Comment: This looks interesting. Some PEAR Coding Standard misses: - Your package is named Map_Projection, so it would go under Math/Map/Projection folder. I'm not sure if "Map" should be a category on its own under Math. Otherwise you could go with MapProjection as package name... Note: This is not a request to change the name of the package. - Please refer to PEAR Coding Standard page for comment block format, especially for the function comment. The "/**functionName" format you're using is not correct. - Put comment block for class properties/members (see PEAR CS again) - Class naming (PEAR CS again). I believe Linear_Projection should become Map_Projection and Lambert_Conformal_Conic_Projection should become Math_Map_Projection_LambertComformalConic and the same for other classes. - Since you say there are many ways to project 3D data into a 2D plan, I suggest to use a factory pattern to set the projection method to be used. Something like: Math_Map_Projection::factory('LambertComformalConic'); - PEAR CS: Add if methods are public, private, protected... - If not done so already, please submit a bug regarding the white space in the Matrix package. Good work otherwise... -Philippe Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=165 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#36671) next »