[PEPr] Comment on Encryption::GPG
| From: | Daniel Convissor | Date: | Thu, 24 Mar 2005 22:56:14 +0000 |
| Subject: | [PEPr] Comment on Encryption::GPG | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-36862@lists.php.net to get a copy of this message | ||
Daniel Convissor (http://pear.php.net/user/danielc) has commented on the proposal for
Encryption::GPG.
Comment:
The encrypt() method should have an optional $armor parameter:
encrypt($data, $username, $armor = true)
If it is true, the encrypted data would be ASCII, but if false the output
would be binary.
Perhaps the encrypt() method should be renamed encryptString().
Similarly, I'd merge the sign() and clearsign() methods into this:
signString($data, $passphrase, $clear = true)
Then, adding the following methods would be great:
encryptFile($file, $username, $armor = true)
decryptFile($file, $passphrase)
signFile($file, $passphrase, $clear = true)
It's not clear to me what to do with the verify() method. Here too, it
might be good to produce verifyString() and verifyFile() or something
along those lines.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=229
--
Sent by PEPr, the automatic proposal system at http://pear.php.net