[PEPr] Comment on System::System_WinDrives

From: Date: Thu, 12 May 2005 17:17:52 +0000
Subject: [PEPr] Comment on System::System_WinDrives
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-37590@lists.php.net to get a copy of this message
Philippe Jausions (http://pear.php.net/user/jausions) has commented on the proposal for System::System_WinDrives. Comment: I suggest you use PEAR::loadExtension() method instead of @dl() calls. The constant names should follow the name of the package define('SYSTEM_WINDRIVE', ...) getGetName() and setGetName() are odd names, why not using getReadNames() and setReadNames(). You may also make your $bGetName, $objAPI and $objFFI private members of the class, and rename them $_readNames, $_objAPI and $_objFFI I would also suggest to rename $arTypeTitles to $typeTitle. AFAIK we don't prefix variable names by their abbreviated types. BTW, you may want to use the constants you declare above as index of that array. Also, there may be confusion about adding the trailing backslash to the drive's name. "C:" would be the drive and "\" the name of the root folder on that drive. Also, make sure you use the new docblock header file. Also for docblock there is only one space between the * and the text following it. I don't know if the phpDocumentor would choke on that. Add the @access doc tag information for members and methods. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=250 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#37590) next »