Re: cvs: pear /MDB2/MDB2/Driver/Manager mssql.php

From: Date: Fri, 17 Jun 2005 18:35:26 +0000
Subject: Re: cvs: pear /MDB2/MDB2/Driver/Manager mssql.php
References: 1 2  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-38152@lists.php.net to get a copy of this message
Daniel Convissor wrote:
Hi Alexander: On Fri, Jun 10, 2005 at 01:34:21PM -0000, Alexander Merz wrote:
alexmerz Fri Jun 10 09:34:21 2005 EDT
 Modified files:                 /pear/MDB2/MDB2/Driver/Manager	mssql.php 
... snip ...
+        if( '' != $database_device || '' != $database_device ) {
+            $onclause = ' ON $database_device$database_size';
Did you really mean to use $database_device twice in the if? Or did you intend:
           if( '' != $database_device || '' != $database_size ) {
Or, even better from a coding standards and readability standpoint (tweaked the spacing and order):
           if ($database_device != '' || $database_size != '') {
I already gave David a slightly tweaked version of the patch. There seem to be issues in this entire feature to begin with to. Thx for bring it up though! regards, Lukas

« previous php.pear.dev (#38152) next »