[PEPr] Comment on Gtk2 Components::Gtk2_IndexedComboBox
| From: | Scott Mattocks | Date: | Fri, 10 Mar 2006 15:13:33 +0000 |
| Subject: | [PEPr] Comment on Gtk2 Components::Gtk2_IndexedComboBox | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-41744@lists.php.net to get a copy of this message | ||
Scott Mattocks (http://pear.php.net/user/scottmattocks) has commented on the proposal for Gtk2
Components::Gtk2_IndexedComboBox.
Comment:
After a quick source review I have a few comments:
- There is no way to set a value by key. You have get_active_key but not
set_active_key.
- I think you should create method aliases that are more inline with PEAR
naming conventions. It will help make the package eaiser to use for people
who are used to working with PEAR packages.
- You don't do any type checking. I don't think PHP-GTK 2 will react
nicely if I try to set a key to an object. It would be nice if you caught
that problem and returned a PEAR_Error before PHP-GTK catches it an spits
out a nasty error message or crashes.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=367
--
Sent by PEPr, the automatic proposal system at http://pear.php.net