[PEPr] Comment on Console::Console_CommandLine
| From: | David Jean Louis | Date: | Fri, 16 Nov 2007 09:28:00 +0000 |
| Subject: | [PEPr] Comment on Console::Console_CommandLine | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-48466@lists.php.net to get a copy of this message | ||
David Jean Louis (http://pear.php.net/user/izi) has commented on the proposal for
Console::Console_CommandLine.
Comment:
Travis,
sorry I forgot to answer to two of your remarks:
>> I would also move the conditional require_once in the constructor.
[...]
I understand the renderer Interface suggestion, and I think it's a great
idea, but why you want to remove the require_once, it is necessary to have
a default renderer, no ?
Also, I would name the default renderer Renderer_Default (ala
Quickform...) instead of Renderer_PlainTextRenderer as you suggested.
>> [...] I would move over to call_user_func() [...]
Sure, that's better! I'll fix this, thanks.
Bye.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=517
--
Sent by PEPr, the automatic proposal system at http://pear.php.net