Re: Coding standard proposal

From: Date: Sun, 20 Apr 2008 15:19:33 +0000
Subject: Re: Coding standard proposal
References: 1 2 3 4  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-49827@lists.php.net to get a copy of this message
David Coallier wrote:
Why is it called Hungarian? Was it invented in Hungary?
http://en.wikipedia.org/wiki/Hungarian_notation#History D I see.
Mose of the 'against' arguments have to do with strongly typed languages where compiler must know the type of variable anyway. Since this is not the case in php, I the list of 'against' is reduced to just one item: "If a variable's type is changed, either the decoration on the name of the variable will be inconsistent with the new type, or the variable's name must be changed." also, this is not very often that an interfase changes the type of variable. And of cause changing the names from arrSomething to strSomething is very easy in most of the IDEs with search/replace function. I still think it's helpful for loosely typed language, it may reduce the number of mistakes the end-user of the class makes. -- Open Source ALL content management with streaming video http://wiki.sharedlog.com

« previous php.pear.dev (#49827) next »