[PEPr] Comment on Streams::Stream_Iterate

From: Date: Thu, 01 May 2008 20:11:15 +0000
Subject: [PEPr] Comment on Streams::Stream_Iterate
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-49953@lists.php.net to get a copy of this message
Michael Gauthier (http://pear.php.net/user/gauthierm) has commented on the proposal for Streams::Stream_Iterate. Comment: I like the concept as long as lots of examples are provided with the final package. Much stream coolness is really cool but hard to figure out at first. Also, the package name is a bit weird. At first I thought it was an Iterator for streams when really it is a stream for Iterator objects or arrays. I'm not sure if there is a better name that would fit PEAR's naming scheme. Maybe Stream_IteratorStream. Is it possible to specify method callbacks like array('MyClass', 'myMethod') or array($object, 'myMethod')? Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=536 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#49953) next »