Re: 2.0.0 (Re: [PEAR-DEV] PEAR 1.9.5 testing)
| From: | till | Date: | Tue, 15 Jul 2014 20:48:28 +0000 |
| Subject: | Re: 2.0.0 (Re: [PEAR-DEV] PEAR 1.9.5 testing) | ||
| References: | 1 2 3 4 5 6 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-55389@lists.php.net to get a copy of this message | ||
On Tue, Jul 15, 2014 at 9:06 PM, Christian Weiske <cweiske@cweiske.de>
wrote:
> Hello Vasil,
>
>
> > > If we release PEAR 1.10 requiring PHP5, then
> > > * PHP4 users will not suffer a BC break since they will be unable to
> > upgrade to 1.10
> > > * PHP5 users will not suffer a BC break since their code will
> > > continue to run happily
>
> I didn't consider that. Of course then we can use proper "static"
> keywords on PEAR::isError() and a couple of other methods in 1.10.
>
> > OK, then I agree about having PEAR 1.10 instead of PEAR 2.0.0. Pyrus
> > is after all itself more or less PEAR 2.0.0 (in fact, Pyrus assumes
> > itself supported if a package requires PEAR installer 2.0.0), so
> > having PEAR1 with a version 2.0.0 is only breaking and complicating
> > things for Pyrus, who's only problem is a lack of people contributing
> > to it.
>
> Yep, that's also a point I didn't pay attention to.
>
>
> So let's make the PHP5 only changes in 1.10.
>
I didn't know this either.
+1 to 1.10 then.
Till