Re: HTML_Javascript
| From: | Martin Jansen | Date: | Sat, 08 Jun 2002 07:16:16 +0000 |
| Subject: | Re: HTML_Javascript | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-6797@lists.php.net to get a copy of this message | ||
On Fri, 7 Jun 2002 11:39:19 -0100, Tal Peer wrote:
>The HTML_Javascript class contains methods for converting php variables into javascript
>variables. it is actually intended for writing a whole script (currently only inside a html
>document, though i will add an optional argument to the constructor f or writing scripts in
>individual files) it supports converting for every type of variable: arrays, strings, integers,
>floats, booleans and null (if you pass an object, it will show the string representation of it).
>
>It also contains wrapper methods for some simple JS operations (write, writeLine and alert, more
>cming soon).
>
>The code is in CVS.
>Comments are always welcome.
I'm a bit afraid that the package name is too general: HTML_JavaScript
implies that the package does basic javascript operations (whatever
this might be). In our case, HTML_JavaScript transforms PHP- into
javascript-variables, which might be a special kind of use. Maybe we
should find a better name for it or split the conversion stuff from the
basic code (write, writeLine etc.)?
- Martin
--
Martin Jansen, <mail@martin-jansen.de>
http://www.martin-jansen.de/