Re: HTML_Javascript

From: Date: Sat, 08 Jun 2002 08:11:01 +0000
Subject: Re: HTML_Javascript
Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-6798@lists.php.net to get a copy of this message
What about moving the conversion stuff to a new class HTML_Javascript_Convert ? -------- Original Message -------- From: mail@martin-jansen.de To: talp@SAFe-mail.net Cc: pear-dev@lists.php.net Subject: Re: [PEAR-DEV] HTML_Javascript Date: Sat, 08 Jun 2002 09:16:16 +0200 > On Fri, 7 Jun 2002 11:39:19 -0100, Tal Peer wrote: > > >The HTML_Javascript class contains methods for converting php variables into javascript > >variables. it is actually intended for writing a whole script (currently only inside a html > >document, though i will add an optional argument to the constructor f or writing scripts in > >individual files) it supports converting for every type of variable: arrays, strings, integers, > >floats, booleans and null (if you pass an object, it will show the string representation of it). > > > >It also contains wrapper methods for some simple JS operations (write, writeLine and alert, > >more cming soon). > > > >The code is in CVS. > >Comments are always welcome. > > I'm a bit afraid that the package name is too general: HTML_JavaScript > implies that the package does basic javascript operations (whatever > this might be). In our case, HTML_JavaScript transforms PHP- into > javascript-variables, which might be a special kind of use. Maybe we > should find a better name for it or split the conversion stuff from the > basic code (write, writeLine etc.)? > > - Martin > -- > Martin Jansen, <mail@martin-jansen.de> > http://www.martin-jansen.de/

« previous php.pear.dev (#6798) next »