Re: Coding guidelines

From: Date: Sun, 22 Jul 2001 12:04:35 +0000
Subject: Re: Coding guidelines
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-963@lists.php.net to get a copy of this message
On Sun, 22 Jul 2001 12:51:27 +0200, Björn Schotte wrote: >to get more comfortable with PEAR coding guidelines, I'm >currently converting PHPLIB's template.inc to suffice PEAR >guidelines. Nice to hear. One more candidate for 'the' PEAR templating engine :-). > function getBlaBlaFooBarBlubbFaselZupp( ... ) > { >Is that the preferred way? Have a look at CODING_STANDARDS: | [...] | Functions should be named using the "studly caps" style (also referred to as | "bumpy case" or "camel caps"). The initial letter of the name is lowercase, | and each letter that starts a new "word" is capitalized. Some examples: | | connect() getData() buildSomeWidget() | | Private class members (meaning class members that an intented to be used | only from within the same class in which they are declared; PHP does not yet | support truly-enforceable private namespaces) are preceeded by a single | underscore. For example: | | _sort() _initTree() $_status | [...] - Martin

« previous php.pear.dev (#963) next »