Fatal error...sometimes
| From: | Robert Karason | Date: | Sun, 12 Jan 2003 19:48:56 +0000 |
| Subject: | Fatal error...sometimes | ||
| Groups: | php.pear.general | ||
| Request: | Send a blank email to pear-general+get-3254@lists.php.net to get a copy of this message | ||
Hi,
I've recently installed Tiki (http://sourceforge.net/projects/tikiwiki/) on
my website. At first I always received this error:
Fatal error: Failed opening required 'DB.php' (include_path='') in
*/tiki/db/tiki-db.php on line 3
where * is the path to my home directory.
The manual says that this error occurs when the include_path is not set to
the PEAR (http://pear.php.net) directory in the php.ini file. I contacted
the company that hosts my web and they told me that the server my site is
currently running on doesn't have PEAR installed and they would move my site
to another server that does have PEAR installed.
Now I got this strange problem. I sometimes get this error now, not
always....and if I get this error I can refresh a couple of times until I
get the Tiki page I requested.
You can try it at http://www.robbik.net/tiki/, if you
don't get this error
to begin with, try surfing the site until you get it, and then do refresh
when you get the error.
I don't understand why this errors occurs sometimes??? Do you think it is
DNS related??
Any suggestions or ideas? I'm all out of ideas :(