RE: [PEAR] Fatal error...sometimes

From: Date: Sun, 12 Jan 2003 20:58:15 +0000
Subject: RE: [PEAR] Fatal error...sometimes
References: 1  Groups: php.pear.general 
Request: Send a blank email to pear-general+get-3255@lists.php.net to get a copy of this message
I've had the same problem trying to use PEAR on a shared server. One solution seems to be to put ini_set("include_path", "ini_get(include_path)"); in an init somewhere, or to explicitly set the include_path in your .htaccess. I found, while trying to debug this problem, that both php_info and ini_get would report the correct include_path, but including code from the system-wide include path would always fail unless I did the above hack. There's an old PHP bug regarding this kind of behaviour - http://bugs.php.net/bug.php?id=15374 - with 4.2.1, but I'm getting it with 4.2.3 as well HTH - Patrick > -----Original Message----- > From: Robert Karason [mailto:robbik@robbik.net] > Sent: Sunday, January 12, 2003 2:49 PM > To: pear-general@lists.php.net > Subject: [PEAR] Fatal error...sometimes > > > Hi, > > I've recently installed Tiki > (http://sourceforge.net/projects/tikiwiki/) on > my website. At first I always received this error: > > Fatal error: Failed opening required 'DB.php' (include_path='') in > */tiki/db/tiki-db.php on line 3 > > where * is the path to my home directory. > > The manual says that this error occurs when the include_path is not set to > the PEAR (http://pear.php.net) directory in the php.ini file. I contacted > the company that hosts my web and they told me that the server my site is > currently running on doesn't have PEAR installed and they would > move my site > to another server that does have PEAR installed. > > Now I got this strange problem. I sometimes get this error now, not > always....and if I get this error I can refresh a couple of times until I > get the Tiki page I requested. > > You can try it at http://www.robbik.net/tiki/, if you > don't get this error > to begin with, try surfing the site until you get it, and then do refresh > when you get the error. > > I don't understand why this errors occurs sometimes??? Do you think it is > DNS related?? > > Any suggestions or ideas? I'm all out of ideas :( > > > > -- > PEAR General Mailing List (http://pear.php.net/) > To unsubscribe, visit: http://www.php.net/unsub.php >

« previous php.pear.general (#3255) next »