Re: PhpDocumentor 1.2.3 directory does not exist
| From: | Alexander Schilling | Date: | Tue, 14 Oct 2003 06:06:26 +0000 |
| Subject: | Re: PhpDocumentor 1.2.3 directory does not exist | ||
| References: | 1 2 | Groups: | php.pear.general |
| Request: | Send a blank email to pear-general+get-8413@lists.php.net to get a copy of this message | ||
Thank you Greg,
you brought me to the right way to search the problem.
I found it. It's nothing todo with phpDocumentor. I use the pear installer
from the root account and phpdoc from my users account. The problem was that
the ~/.pearrc file in my user account had relative paths to all directories
which didn't work in pear itself (pear list shows empty list) and
phpDocumentor greater 1.2.1.
I removed the file, called pear list and everything worked including
phpDocumentor.
FYI I used the newest pear 1.3b2 with my own configuration file outside the
/user directory.
Best regards
Alexander
Am Montag, 13. Oktober 2003 17:02 schrieb Greg Beaver:
> Hi Alexander,
>
> What is your PEAR version? I tested the installation of phpDocumentor
> with PEAR 1.3b2, and did a clean install of phpDocumentor 1.2.1, then
> pear upgrade phpDocumentor, and was able to use this command-line with
> no trouble:
>
> phpdoc -t ./test_docs -d . -o HTML:frames:DOM/earthli
>
> Are you calling phpdoc directly? From a script?
>
> If you find that it suddenly works after upgrading PEAR, I will add a
> dependency on a recent PEAR version and re-release.
>
> Regards,
> Greg
>
> Alexander Schilling wrote:
> > I used phpDocumentor 1.2.1 since two months and it worked great.
> >
> > Now I just tried to upgrade it but can't get it to work. Both versions
> > 1.2.2.1 and 1.2.3 give me the same error:
> >
> > Sorting page elements...done
> > Formatting @uses list...done
> >
> > ERROR: template directory
> > "./pear/data/PhpDocumentor/phpDocumentor/
> > Converters/HTML/frames/templates/DOM/earthli/" does not exist
> > ERROR: template directory
> > "./pear/data/PhpDocumentor/phpDocumentor/
> > Converters/HTML/frames/templates/DOM/earthli/" does not exist
> >
> > The path exists in the under /usr/share/php/.....
> > I tried to solve it by making the above path reachable from the current
> > directory by soft link but nothing changed.
> >
> > What else can I do to find the problem?
> >
> > I use PHP 4.3.1 (cgi), Copyright (c) 1997-2002 The PHP Group
> > Zend Engine v1.3.0, Copyright (c) 1998-2002 Zend Technologies
--
Alexander Schilling