Re: richy and tal's packages
| From: | Arnaud Limbourg | Date: | Wed, 28 Apr 2004 17:10:55 +0000 |
| Subject: | Re: richy and tal's packages | ||
| References: | 1 2 3 | Groups: | php.pear.qa |
| Request: | Send a blank email to pear-qa+get-1179@lists.php.net to get a copy of this message | ||
> Whoever does take it, PEAR desperately needs a OO-based File class
> instead of the current static method collections (File2? File_Object?).
>
> Directory_Lister or something along those linse might be a better name.
> Anyways, if it is a different competing package, does anyone see a
> problem with that? Josh and I have been talking about writing such a
> beast to replace the Io class in phpDocumentor - it would also be used
> in PEAR_PackageFileManager, and by any project that needs the ability to
> selectively list files with ignore/inclusion by wildcards.
I remember Richard once mentionning they should have gone that way, instead of static methods ;)
Anyway, I think it would be a great addition to PEAR.
Arnaud.