Re: New extension 'sync'

From: Date: Mon, 05 May 2014 13:31:03 +0000
Subject: Re: New extension 'sync'
References: 1  Groups: php.pecl.dev 
Request: Send a blank email to pecl-dev+get-11807@lists.php.net to get a copy of this message
2014-05-04 8:13 GMT+09:00 Thomas Hruska <thruska@cubiclesoft.com>: > I think I'm ready for a preliminary code review for PECL inclusion. I've > been looking over the various documents on the account request page and I > see a few potential issues, but I'd like feedback at this point for > guidance/pointers/tips specific to actions I actually need to take vs. > nice-to-haves before applying for a PECL account. I've built your extension with php5.3 but it failed. You need to define zval *tmp here. ``` #if PHP_VERSION_ID < 50399 zend_hash_copy(obj->std.properties, &ce->default_properties, (copy_ctor_func_t)zval_add_ref, (void *)&tmp, sizeof(zval *)); ``` Sync_Mutex class name would be SyncMutex better. please check User Functions/Methods Naming Conventions #7. http://git.php.net/?p=php-src.git;a=blob_plain;f=CODING_STANDARDS;hb=HEAD Why do you choose multi licensing for php extension? Single license would be simpler.

« previous php.pecl.dev (#11807) next »