Re: Re: cvs: pecl(PHP_5_2) /intl php_intl.c /intl/grapheme grapheme.h grapheme_string.c
| From: | Pierre Joye | Date: | Wed, 09 Apr 2008 13:39:05 +0000 |
| Subject: | Re: Re: cvs: pecl(PHP_5_2) /intl php_intl.c /intl/grapheme grapheme.h grapheme_string.c | ||
| References: | 1 2 | Groups: | php.pecl.dev |
| Request: | Send a blank email to pecl-dev+get-5358@lists.php.net to get a copy of this message | ||
On Wed, Apr 9, 2008 at 2:18 PM, Derick Rethans <derick@php.net> wrote:
> On Wed, 9 Apr 2008, Hannes Magnusson wrote:
>
> > bjori Wed Apr 9 11:58:37 2008 UTC
> >
> > Modified files: (Branch: PHP_5_2)
> > /pecl/intl php_intl.c
> > /pecl/intl/grapheme grapheme_string.c grapheme.h
> > Log:
> > Fix reflection
> >
> >
>
> > PHP_FE( grapheme_extract, grapheme_3_args )
> > - PHP_FE( grapheme_extractB, grapheme_3_args )
> > + PHP_FE( grapheme_extractb, grapheme_3_args )
>
> Uh, what happened to descriptive function names here. What in ****'s
> name is the difference between grapheme_extract and grapheme_extractb?
Naming conventions have not been created only for the sake of having
conventions but to be applied.
I'm also wondering if it is correct to have these functions in intl
and not in unicode. I also wonder where it was discussed or planed. It
is getting really hard to understand where they are heading.
Cheers,
--
Pierre
http://blog.thepimp.net | http://www.libgd.org