Re: [PHP4BETA] Re: SESS: objects containing objects *final statement*(?)please read!
| From: | Stig S. Bakken | Date: | Fri, 25 Feb 2000 19:42:46 +0000 |
| Subject: | Re: [PHP4BETA] Re: SESS: objects containing objects *final statement*(?)please read! | ||
| References: | 1 | Groups: | php.version4 |
| Request: | Send a blank email to php-version4+get-10992@lists.php.net to get a copy of this message | ||
Zeev Suraski wrote:
>
> On Fri, 25 Feb 2000, Andrei Zmievski wrote:
>
> > On Fri, 25 Feb 2000, Stig Bakken wrote:
> > > I was thinking about storing it in the object, if two extra character
> > > pointers doesn't mean too much overhead. Actually, a better name would
> > > be set_object_serialize_method(), because it would only let you set one
> > > at a time.
> >
> > Sorry, storing them how? In object properties? Under what key?
>
> I completely agree with Thies here; There's no reason not to make these
> standard names at the language level. As a matter of fact, there's
> already a function in Zend called to_string(), that is used to print out
> the object, if it exists (instead of printing 'Object').
~ (doing the wave) and +1 for making it part of the language.
> I think the best approach would be to change the semantics of to_string()
> to actually return a string, instead of printing it out, so that it could
> be used for serialization.
Wouldn't that more or less do the same as serialize? I agree that it
should return a value in any case.
- Stig