Re: [PHP4BETA] cvs: php4 / php.h /ext/standard/ basic_functions.c crypt.c datetime.c dl.h dns.c file.c microtime.c php_crypt.h

From: Date: Fri, 26 May 2000 18:17:15 +0000
Subject: Re: [PHP4BETA] cvs: php4 / php.h /ext/standard/ basic_functions.c crypt.c datetime.c dl.h dns.c file.c microtime.c php_crypt.h
References: 1  Groups: php.version4 
Request: Send a blank email to php-version4+get-15816@lists.php.net to get a copy of this message
On Fri, 26 May 2000, Andrei Zmievski wrote: > On Fri, 26 May 2000, Hartmut Holzgraefe wrote: > > have a new function like > > > > PHP_FUNCTION(warn_not_available) > > { > > php_error(E_WARNING, "%s() is not supported in this PHP > > build",get_active_function_name()); > > RETURN_FALSE; > > } > > > > and function_entries like > > > > /* functions from crypt.c */ > > #ifdef HAVE_CRYPT > > PHP_FE(crypt, NULL) > > #else > > PHP_FALIAS(crypt, warn_not_available, NULL) > > #endif > > That's a better idea. But then warn_not_available() becomes exposed to > user-space... Why? It doesn't... BTW, even though we'll be dropping this solution altogether, if you ever write macros that have side effects (as opposed to just being a value), please make sure you use a notation of FOO(); instead of just FOO; It makes the code more readable. Zeev -- Zeev Suraski <zeev@zend.com> http://www.zend.com/

« previous php.version4 (#15816) next »