Re: [PHP4BETA] PHP_FUNCTION

From: Date: Fri, 23 Jul 1999 20:52:53 +0000
Subject: Re: [PHP4BETA] PHP_FUNCTION
References: 1  Groups: php.version4 
Request: Send a blank email to php-version4+get-2644@lists.php.net to get a copy of this message
On Fri, 23 Jul 1999, Andrey Zmievski wrote: > #define PHP_NAMED_FUNCTION(name) void name(INTERNAL_FUNCTION_PARAMETERS) > #define PHP_FUNCTION(name) PHP_NAMED_FUNCTION(php3_##name) > > #define PHP_NAMED_FE(php_name, name, arg_types) { #php_name, name, arg_types > }, > #define PHP_FE(name, arg_types) PHP_NAMED_FE(name, php3_##name, arg_types) > #define PHP_FALIAS(name, alias, arg_types) PHP_NAMED_FE(name, php3_##alias, > arg_types) > > Shouldn't these be changed to use 'php' instead of 'php3'? There's a whole whack of functions called php3_something that should be renamed, too, but I think we should wait until most of the development has moved over to php4. At least oci8 uses the same code on php3 and php4. But changing what these macros expand to can be done anytime, feel free. - Stig

« previous php.version4 (#2644) next »