Re: [PHP4BETA] PHP_FUNCTION
| From: | Zeev Suraski | Date: | Sat, 24 Jul 1999 00:38:38 +0000 |
| Subject: | Re: [PHP4BETA] PHP_FUNCTION | ||
| References: | 1 | Groups: | php.version4 |
| Request: | Send a blank email to php-version4+get-2655@lists.php.net to get a copy of this message | ||
At 22:52 23/07/99 , Stig Bakken wrote:
On Fri, 23 Jul 1999, Andrey Zmievski wrote: #define PHP_NAMED_FUNCTION(name) void name(INTERNAL_FUNCTION_PARAMETERS) #define PHP_FUNCTION(name) PHP_NAMED_FUNCTION(php3_##name) #define PHP_NAMED_FE(php_name, name, arg_types) { #php_name, name, arg_types }, #define PHP_FE(name, arg_types) PHP_NAMED_FE(name, php3_##name, arg_types) #define PHP_FALIAS(name, alias, arg_types) PHP_NAMED_FE(name, php3_##alias, arg_types) Shouldn't these be changed to use 'php' instead of 'php3'? There's a whole whack of functions called php3_something that should be renamed, too, but I think we should wait until most of the development has moved over to php4. At least oci8 uses the same code on php3 and php4. But changing what these macros expand to can be done anytime, feel free.I think there are a lot of functions that have their prototypes defined with PHP_FUNCTION(), but their actual body defined as php3_functionname(). Changing PHP_FUNCTION() would require you to change the body declaration to use PHP_FUNCTION() as well. We'd have to do it at some point or another - if you're upto it - as Stig said - feel free :) Zeev -- Zeev Suraski <zeev@zend.com> http://www.zend.com/ For a PGP public key, finger bourbon@netvision.net.il