Re: com web/shared: added possibility to emit <head> elements before the CSS <link>s (needed for easier maintainance of DokuWiki); did some minor
style tweaks: styles/wiki.css templates/header.inc
| From: | Hannes Magnusson | Date: | Wed, 25 Mar 2015 14:29:56 +0000 |
| Subject: | Re: com web/shared: added possibility to emit <head> elements before the CSS <link>s (needed for easier maintainance of DokuWiki); did some minor style tweaks: styles/wiki.css templates/header.inc |
||
| References: | 1 | Groups: | php.webmaster |
| Request: | Send a blank email to php-webmaster+get-20963@lists.php.net to get a copy of this message | ||
On Tue, Mar 24, 2015 at 3:41 PM, Christoph Michael Becker <cmb@php.net> wrote:
> Commit: a7802835d7f17cc7234211393c2d11ae214d1290
> Author: Christoph M. Becker <cmbecker69@gmx.de> Tue, 24 Mar 2015 23:41:59
> +0100
> Parents: 65940f791d7f97257d3a38c8595f9330f3a4f7dc
> Branches: master
>
> Link:
> http://git.php.net/?p=web/shared.git;a=commitdiff;h=a7802835d7f17cc7234211393c2d11ae214d1290
>
> Log:
> added possibility to emit <head> elements before the CSS <link>s (needed for easier
> maintainance of DokuWiki); did some minor style tweaks
>
> Changed paths:
> M styles/wiki.css
> M templates/header.inc
>
>
> Diff:
> diff --git a/styles/wiki.css b/styles/wiki.css
> index 88df37f..b519b97 100644
> --- a/styles/wiki.css
> +++ b/styles/wiki.css
> @@ -1051,36 +1051,15 @@ li code {
> font-style: italic;
> }
>
> -/* messages with msg() */
> -
> -div.error,
> -div.info,
> -div.success,
> -div.notify {
> - color: #000;
> - border: 1px solid;
> - font-size: 90%;
> - margin: 0 0 0.5em;
> - padding: 0.4em;
> - overflow: hidden;
> - border-radius: 5px;
> -}
> -div.error {
> - background-color: #fcc;
> - border-color: #ebb;
> -}
> -
> -div.info {
> - background-color: #ccf;
> - border-color: #bbe;
> +.dokuwiki form.changes ul li span,
> +.dokuwiki form.changes ul li a {
> + vertical-align: baseline;
> }
>
> -div.success {
> - background-color: #cfc;
> - border-color: #beb;
> +div.table {
> + overflow-x: scroll;
> }
>
> -div.notify {
> - background-color: #ffc;
> - border-color: #eeb;
> +form[name=doodle__form] td.rightalign {
> + text-align: left;
> }
> diff --git a/templates/header.inc b/templates/header.inc
> index 6111d13..39979b1 100644
> --- a/templates/header.inc
> +++ b/templates/header.inc
> @@ -7,9 +7,10 @@
> * $TITLE = "Awesome Website"; // Page title
> * $SUBDOMAIN = "people"; // Subdomain/Project
> * $LINKS = array(
> - * $HEAD_RAND = ""; // Random extra values needed for in <head>
> * array("href" => "/link.php", "text" =>
> "Link text")
> * ); // Menu menu links
> + * $HEAD_WIKI = ""; // DokuWiki's extra <head> elements
> + * $HEAD_RAND = ""; // Random extra values needed for in <head>
> * $CSS = array("/styles/local.css"); // (relative to /shared)
> * $SEARCH = array(
> * "method" => "get",
> @@ -22,6 +23,7 @@
> isset($TITLE) || $TITLE = "Hypertext Preprocessor";
> isset($SUBDOMAIN) || $SUBDOMAIN = "";
> isset($LINKS) || $LINKS = array();
> +isset($HEAD_WIKI) || $HEAD_WIKI = "";
> isset($HEAD_RAND) || $HEAD_RAND = "";
> isset($CSS) || $CSS = array();
> isset($SEARCH) || $SEARCH = array();
> @@ -36,6 +38,7 @@ $current_time = time();
>
> <title>PHP: <?=$TITLE ?></title>
>
> + <?=$HEAD_WIKI ?>
That is a very specific name of that variable..
How about $HEAD_PRE_LINKS and rename HEAD_RAND to $HEAD_POST_LINKS ?
-Hannes