Re: php 5.5+ --with-pdo-pgsql

From: Date: Tue, 19 Jan 2016 16:25:55 +0000
Subject: Re: php 5.5+ --with-pdo-pgsql
References: 1 2  Groups: php.windows 
Request: Send a blank email to php-windows+get-31376@lists.php.net to get a copy of this message
On Tue, Jan 19, 2016 at 9:51 PM, Toby Hart Dyke <list@hartdyke.com> wrote: > > The Windows version of PHP doesn't quite work like that. All you should need > to do is load the extension. Have you uncommented these lines (removed the > semi-colon)?: > > ;extension=php_pgsql.dll > ;extension=php_pdo_pgsql.dll > > Once you've done that, restart Apache and you should be good to go. > > Toby > > On 17/01/2016 01:03, Peter Gostelow wrote: >> >> Hi, >> >> I installed an 'EnterpriseDB-ApachePHP' binary package that included >> apache >> 2.2, postgresql 9.2, and php 5.4. That was years ago. I now want to >> upgrade >> to to php 5.5 and higher. I have installed apache 2.4, postgresql 9.3, and >> php 5.5. They work fine. >> >> The problem is that the php I downloaded from windows.php.net was not >> configured with pdo postgres. I cannot use VC11 to compile my own php >> because it doesn't work with vista system. Google hasn't turned up any php >> binaries with pg enabled and it seems EnterpriseDB have dropped their >> support for apache/php. >> >> Either I am missing something, should switch to gnu/linux, or beg someone >> to >> build a binary with pg support. >> >> Any suggestions? Also if you use fastcgi, the VC versions do not have to match between PHP and Apache. -- Pierre @pierrejoye | http://www.libgd.org

« previous php.windows (#31376) next »