Bug #17736: After install php 4.2.1, Apache couldn't start

From: Date: Thu, 13 Jun 2002 06:25:39 +0000
Subject: Bug #17736: After install php 4.2.1, Apache couldn't start
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10306@lists.php.net to get a copy of this message
From: stevenleong@yahoo.com Operating system: Redhat Linux 7.3 PHP version: 4.2.1 PHP Bug Type: Apache2 related Bug description: After install php 4.2.1, Apache couldn't start Dear, Currently, I installed Apache 2.0.36 as my DSO web server. I tried to upgrade my current php 4.1.2-7 to php 4.2.1. I used the following comment to install >./configure --with-mysql --with-apxs2=/usr/local/apache-2.0.36/bin/apxs >make >make install Then I copied php.ini-dist to /etc/php.ini Then I tried >apachectl start >Syntax error on line 253 of /usr/local/apache-2.0.36/conf/httpd.conf: Cannot load /usr/local/apache-2.0.36/modules/libphp4.so into server: /usr/local/apache-2.0.36/modules/libphp4.so: undefined symbol: core_globals_id /usr/local/apache-2.0.36/bin/apachectl start: httpd could not be started I didn't understand why core_globals_id related to this php. Please let me know as soon as possible if you find a solution. I appreciate it. Thanks, Steven -- Edit bug report at http://bugs.php.net/?id=17736&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=17736&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=17736&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=17736&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=17736&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=17736&r=support Expected behavior: http://bugs.php.net/fix.php?id=17736&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=17736&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=17736&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=17736&r=globals

« previous php.bugs (#10306) next »