Bug #17736 Updated: After install php 4.2.1, Apache couldn't start

From: Date: Thu, 13 Jun 2002 17:51:13 +0000
Subject: Bug #17736 Updated: After install php 4.2.1, Apache couldn't start
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10367@lists.php.net to get a copy of this message
ID: 17736 Updated by: stevenleong@yahoo.com Reported By: stevenleong@yahoo.com -Status: Feedback +Status: Open Bug Type: Apache2 related Operating System: Redhat Linux 7.3 PHP Version: 4.2.1 New Comment: After installed the latest snapshot, I got this error when running apachectl start [root@dev php]# $APACHE_HOME/bin/apachectl start Syntax error on line 265 of /usr/local/apache-2.0.36/conf/httpd.conf: Invalid command 'AddModule', perhaps mis-spelled or defined by a module not included in the server configuration /usr/local/apache-2.0.36/bin/apachectl start: httpd could not be started I looked at httpd.conf There are two lines added. LoadModule php4_module modules/libphp4.so AddModule mod_php4.c Did I miss something in Apache 2? How come it doesn't recognize AddModule? Do you have any idea? Reg, Steven Previous Comments: ------------------------------------------------------------------------ [2002-06-13 09:13:15] sniper@php.net Please try the latest CVS snapshot of PHP: http://snaps.php.net/php4-latest.tar.gz ------------------------------------------------------------------------ [2002-06-13 02:25:38] stevenleong@yahoo.com Dear, Currently, I installed Apache 2.0.36 as my DSO web server. I tried to upgrade my current php 4.1.2-7 to php 4.2.1. I used the following comment to install >./configure --with-mysql --with-apxs2=/usr/local/apache-2.0.36/bin/apxs >make >make install Then I copied php.ini-dist to /etc/php.ini Then I tried >apachectl start >Syntax error on line 253 of /usr/local/apache-2.0.36/conf/httpd.conf: Cannot load /usr/local/apache-2.0.36/modules/libphp4.so into server: /usr/local/apache-2.0.36/modules/libphp4.so: undefined symbol: core_globals_id /usr/local/apache-2.0.36/bin/apachectl start: httpd could not be started I didn't understand why core_globals_id related to this php. Please let me know as soon as possible if you find a solution. I appreciate it. Thanks, Steven ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17736&edit=1

« previous php.bugs (#10367) next »