Bug #17736 Updated: After install php 4.2.1, Apache couldn't start

From: Date: Thu, 13 Jun 2002 13:13:15 +0000
Subject: Bug #17736 Updated: After install php 4.2.1, Apache couldn't start
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10332@lists.php.net to get a copy of this message
ID: 17736 Updated by: sniper@php.net Reported By: stevenleong@yahoo.com -Status: Open +Status: Feedback Bug Type: Apache2 related Operating System: Redhat Linux 7.3 PHP Version: 4.2.1 New Comment: Please try the latest CVS snapshot of PHP: http://snaps.php.net/php4-latest.tar.gz Previous Comments: ------------------------------------------------------------------------ [2002-06-13 02:25:38] stevenleong@yahoo.com Dear, Currently, I installed Apache 2.0.36 as my DSO web server. I tried to upgrade my current php 4.1.2-7 to php 4.2.1. I used the following comment to install >./configure --with-mysql --with-apxs2=/usr/local/apache-2.0.36/bin/apxs >make >make install Then I copied php.ini-dist to /etc/php.ini Then I tried >apachectl start >Syntax error on line 253 of /usr/local/apache-2.0.36/conf/httpd.conf: Cannot load /usr/local/apache-2.0.36/modules/libphp4.so into server: /usr/local/apache-2.0.36/modules/libphp4.so: undefined symbol: core_globals_id /usr/local/apache-2.0.36/bin/apachectl start: httpd could not be started I didn't understand why core_globals_id related to this php. Please let me know as soon as possible if you find a solution. I appreciate it. Thanks, Steven ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17736&edit=1

« previous php.bugs (#10332) next »