Bug #16518 Updated: undefined symbol: stat
| From: | sniper@php.net | Date: | Sun, 16 Jun 2002 00:42:12 +0000 |
| Subject: | Bug #16518 Updated: undefined symbol: stat | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-10533@lists.php.net to get a copy of this message | ||
ID: 16518
Updated by: sniper@php.net
Reported By: mitch@youngfamily.org
-Status: Open
+Status: Feedback
Bug Type: Informix related
Operating System: RedHat 7.2 / Debian 3.0
PHP Version: 4.0CVS-2002-04-09
New Comment:
This snapshot _should_ fix the problem:
http://snaps.php.net/php4-latest.tar.gz
It works fine for me with the 2.70.UC3 which is the latest I found from
the informix site.
--Jani
Previous Comments:
------------------------------------------------------------------------
[2002-04-09 15:35:43] mitch@youngfamily.org
I have successfully got apache-2.0.35 & php4.2-CVS to work fine
together, but when I recompile php with informix support it compiles
fine but when
I try to start apache2 I get the folloing message.
[root@redhat bin]# ./apachectl start
Syntax error on line 217 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server:
/opt/informix/lib/esql/libthgen.so: undefined symbol: stat
./apachectl start: httpd could not be started
[root@redhat bin]#
It appears to be a problem with the latest version of the Informix CSDK
2.70 because I downgraded to 2.60 and everything compiled and runs fine
after the downgrade!
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16518&edit=1