Bug #16518: undefined symbol: stat
| From: | mitch at youngfamily dot org | Date: | Tue, 09 Apr 2002 19:35:44 +0000 |
| Subject: | Bug #16518: undefined symbol: stat | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-4466@lists.php.net to get a copy of this message | ||
From: mitch@youngfamily.org
Operating system: RedHat 7.2 / Debian 3.0
PHP version: 4.0CVS-2002-04-09
PHP Bug Type: Informix related
Bug description: undefined symbol: stat
I have successfully got apache-2.0.35 & php4.2-CVS to work fine together,
but when I recompile php with informix support it compiles fine but when
I try to start apache2 I get the folloing message.
[root@redhat bin]# ./apachectl start
Syntax error on line 217 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server:
/opt/informix/lib/esql/libthgen.so: undefined symbol: stat
./apachectl start: httpd could not be started
[root@redhat bin]#
It appears to be a problem with the latest version of the Informix CSDK
2.70 because I downgraded to 2.60 and everything compiled and runs fine
after the downgrade!
--
Edit bug report at http://bugs.php.net/?id=16518&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=16518&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=16518&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=16518&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=16518&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=16518&r=support
Expected behavior: http://bugs.php.net/fix.php?id=16518&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=16518&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=16518&r=submittedtwice