#16518 [Com]: undefined symbol: stat
| From: | fish at iface dot co dot uk | Date: | Tue, 01 Oct 2002 13:37:22 +0000 |
| Subject: | #16518 [Com]: undefined symbol: stat | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20923@lists.php.net to get a copy of this message | ||
ID: 16518
Comment by: fish@iface.co.uk
Reported By: mitch@youngfamily.org
Status: No Feedback
Bug Type: Informix related
Operating System: RedHat 7.2 / Debian 3.0
PHP Version: 4.0CVS-2002-04-09
New Comment:
I can confirm that it's an Informix problem - got identical error
running make test while building DBD-Informix 1.00.PC2
Previous Comments:
------------------------------------------------------------------------
[2002-07-16 01:00:09] php-bugs@lists.php.net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2002-06-15 20:42:12] sniper@php.net
This snapshot _should_ fix the problem:
http://snaps.php.net/php4-latest.tar.gz
It works fine for me with the 2.70.UC3 which is the latest I found from
the informix site.
--Jani
------------------------------------------------------------------------
[2002-04-09 15:35:43] mitch@youngfamily.org
I have successfully got apache-2.0.35 & php4.2-CVS to work fine
together, but when I recompile php with informix support it compiles
fine but when
I try to start apache2 I get the folloing message.
[root@redhat bin]# ./apachectl start
Syntax error on line 217 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server:
/opt/informix/lib/esql/libthgen.so: undefined symbol: stat
./apachectl start: httpd could not be started
[root@redhat bin]#
It appears to be a problem with the latest version of the Informix CSDK
2.70 because I downgraded to 2.60 and everything compiled and runs fine
after the downgrade!
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16518&edit=1